Making a Printed Circuit Board

Steps for making a PCB in KiCad


I make printed circuit boards but only occasionally, so I don’t remember all the many steps. There is a fantastic video tutorial set, Getting to Blinky (now in 5.0) by Contextual Electronics that goes through all the steps necessary to build a board. However, enough time passes between each time I build a board that I need to re-watch the 1.5 hours of video to remind myself of all the steps. Here is a set of steps broken down from Getting to Blinky 5.0 with references to where they occur in the videos. It does not substitute for watching the videos at first, but my hope is that one can use the notes for later projects, and one could watch only where one gets stuck. Enjoy!


Step 0. Install KiCad.


  1. Install KiCad. Consider making a donation.

  2. Open KiCad


Step 1. Make Project


  1. Make a Project (File Menu -> New). Save it in a new folder.


Step 2. Make Schematic


  1. If necessary, make symbols for unknown parts (video: Making Schematic Symbols)

    1. Go to Schematic Symbol Editor, looks like an amplifier chip with a pencil (~2:00)

    2. Create a new library, choose File -> New Library (4:07)

    3. Save the library within your project

    4. Right click on your library in the list, choose “New Symbol” (5:05)

    5. Give it a name, generally use default values otherwise.

    6. Initially, all the symbol elements are right on top of each other. Use m to move the name label above the symbol U Move the symbol U down with m key. (5:33)

    7. Use the “Add pin” symbol to add your pins. (7:06)

    8. Move and rotate the pins so they are arranged around your schematic. (10:00). The PIN name should be on the interior of the schematic (the type is on the outside).

    9. Drag a rectangle around your symbol (10:50). Add a background color if you want (11:50).

    10. Make sure to save (there will be an * in the filename if you haven’t saved).

    11. Close the Schematic Symbol Editor, repeat to make any new symbols.

  2. Draw your schematic (video: Making the Schematic)

    1. Use A to add all of the symbols for your components. You will be prompted to search for the symbol in the library. If you need to add a symbol that isn’t in the library, make the symbols as described above. (2:00) Common symbols: C (for a capacitor), R (for a resistor), LED (for LED), GND (ground). Set the values of resistors and capacitors to indicate the amount of resistance or capacitance.

    2. Connect the wires using the wire tool (6:55). Insert power flag symbols for power and ground (11:48). Make sure pins that are intentionally not connected are marked as not connected with an x (12:30).

    3. Check that everything is hooked up correctly.

    4. Again, check that everything is hooked up correctly.

    5. If you’re like me and tend not to see things the first two times, check a third time.

    6. Run the anatator (Tools -> Annotate Schematic) to annotate the symbols.

    7. Run the Electronic Rules Checker to check for errors (Inspect -> Electronic Rules Checker). (9:10)


Step 3. Make Footprints for Symbols


Here we identify the physical dimensions of the components we will use (video: Associating Symbol and Footprint). The physical characteristics that correspond to each symbol in the schematic are termed Footprints. For example, there are a million different resistors. What are the exact sizes of the resistors you will actually use on the board? These are the footprints.


  1. Go to tools -> Assign Footprints

  2. Associate each symbol with a footprint.

  3. There are unbelievably many choices of course. Suggest using 0805 packages unless there is a reason to differ. Suggestions:

    Resistors_SMD:R0805_2012Metric_Pad1.20x1.40mm_HandSolder (5:00)
    (an 0805 resistor, which are easy to find; hand solder means pads are a tad larger)
    Capacitors_SMD:C_0805_2012Metric_Pad1.18x1.45mm_HandSolder (8:33)
    LEDs_SMD:LED_0805_2012_Metric_Pad1.15x1.40mm_HandSolder (8:41)
    Generic ICs: Go to Package_SO:8_3.9x4.9mm_P1.27 (8 pin) (6:00)

  4. If necessary, create custom footprints using the footprint editor (video: Generating Custom Foorptings)

    1. Launch Footprint Editor from the launcher

    2. Choose New Library (1:21), give it a name and put it in your project

    3. Right-click the new library and choose New Footprint (2:22)

    4. Give it the name of your part

    5. View the part’s datasheet

    6. Add the first pad; edit it (e) to have the right shape and size (4:42)

    7. Add all pads.

    8. Pick one pad to be the origin, and then edit the X/Y positions of all pads so they are in the right spot (6:31)

    9. Draw a silkscreen boundary so it looks nice on the board

    10. Draw a set of lines in “Courtyard” layer so other parts can’t be closer (12:30)

    11. Associate the new footprint with your symbols on the schematic

  5. Make your initial PCB by going to Tools -> Update PCB from Schematic (13:10)


Step 4. Lay out the board (video: Finishing the Layout)


  1. Define the shape of the board by drawing an outline in the “Edge.Cuts” layer

  2. Layout the physical items (6:00). Some tips:

    1. Under the view menu, turn on / off Ratsnest view to show /hide the intended connections. Avoid intersections in wires as you layout the board. (4:22)

    2. Use F (or right click on an object and choose flip side) to move an item to the front or back. (3:23)

    3. Draw wires using the X button. Make sure grid is set to a fine setting (say, 0.1 mm ) so you have freedom to move the wires. (11:00)

    4. Make a ground plane by choosing Add a Filled Zone, and put it on the back usually (13:00)

    5. Add vias by hitting V while you are drawing wires

    6. Make sure to update your ground plane after finishing your other drawings

    7. Make sure you move the silkscreen items out of the way by going to the silk screen layer and moving the pieces away from the copper (video: Output Files for Manufacturing, 3:00)

    8. Add some text

  3. When you are finished, run the Design Rules Checker (Inspect -> Design Rules Checker)


Step 5. Print the board


  1. If you print at OSH Park, just drag your .pcb file into their submission window and you’re done! They are great for the small runs that we typically do. (Maybe they are even great for large runs, I don’t have experience.)

  2. If you want to prepare Gerber plotting instructions for each layer, then see the video Output Files for Manufacturing