-Techniques and tricks‎ > ‎Matlab‎ > ‎

Export Matlab figures to Illustrator


To export figures in Matlab to Illustrator, do the following:
  1. Select your figure. Now, choose File menu, Save As...
  2. Save the file as an .eps file (encapsulated postscript file)
  3. In Illustrator, you can open this .eps file
  4. The objects in the figure are likely to be "grouped". If this is not what you want, select the objects and choose Ungroup from the Object menu.
  5. The various parts of the figure are further likely to be organized into structures that you may or may not want. The 3 structure types that are common are:
    1. Clipping mask (you can release this by selecting the objects that are collected and choosing Object menu, Clipping mask submenu, Release Clipping Mask).
    2. Compound path (you can release this by selecting the objects that are collected and choosing Object menu, Compound path submenu, Release Compound Path).
    3. Grouping (you can release items in a group by choosing Object menu, Ungroup).
Comments